Trouble accessing Athenian
Incident Report for Athenian
Resolved
This incident has been resolved.
Posted Jan 10, 2022 - 23:41 CET
Investigating
Several users have reported having trouble accessing Athenian. We're investigating.
Posted Jan 10, 2022 - 23:11 CET
This incident affected: app.athenian.co (Athenian Application, Athenian API).