Performance Incident

Incident Report for Athenian

Resolved

This incident has been resolved.
Posted Jun 21, 2022 - 13:00 CEST

Investigating

We are currently investigating this issue.
Posted Jun 21, 2022 - 12:55 CEST
This incident affected: app.athenian.co (Cloud Infrastructure).