Global Outage
Incident Report for Athenian
Resolved
This incident has been resolved.
Posted Mar 17, 2023 - 09:52 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 17, 2023 - 09:47 CET
This incident affected: app.athenian.co (Athenian Application).