Inconsistent and unreliable cycle time data
Incident Report for Athenian
Resolved
After 24 hours we see our event processing queue stable. This means we are able to process data as it arrives to our system.
Posted Jan 14, 2023 - 23:12 CET
Monitoring
Monitoring to validade issue is mitigate.
Posted Jan 13, 2023 - 23:47 CET
Update
Still investigating the issue an doing mitigation activities to minimize impacted customers.
Posted Jan 13, 2023 - 20:14 CET
Investigating
Athenian is experiencing inconsistent release events for repos that have the release strategy set to Automatic or Default Branch. Not all repos are affected and we are investigating the root cause. Release data, PR cycle time and Lead time data can be affected, and will be recalculated and recovered as soon as the incident is fixed.

Customers can rely on all the remaining data, as that stands accurate and is not affected by this event.
Posted Jan 13, 2023 - 19:08 CET
This incident affected: app.athenian.co (Athenian API, Athenian Data Ingestion).